Wednesday, March 27, 2013

SharePoint 2010: The expected version of the product was not found on the system.

While I was trying to install a new CU I encountered an error. It simply says that "the expected version of the product was not found on the system.". Problem is, that I am sure, I DO have an expected version installed.

So what to do now?

There is a cmd-command for that:

"CU-NAME PACKAGE.BYPASS.DETECTION.CHECK=1"

With "PACKAGE.BYPASS.DETECTION.CHECK=1" the installation will run smoothly without checking the package version. Worked for me, even Configuration Wizard shows no problem and the farm still runs all right.